Exec format error

Exec format error

Postby davedontmind » Tue Jan 03, 2017 1:51 pm

I've just purchased ExaGear for my Raspberry Pi Model 3 B, with the intention of using it to run a Teamspeak server (using these instructions).

However, I'm having trouble right from the start.

I installed ExaGear ok, and it seems to be running ok (the arch command reports "i686" as the architecture), but some commands aren't working.

For example:

Code: Select all
pi@raspberrypi:~ $ arch
armv7l
pi@raspberrypi:~ $ exagear
Starting /bin/bash  in the guest image /opt/exagear/images/debian-8
pi@raspberrypi:~ $ arch
i686
pi@raspberrypi:~ $ sudo
bash: /usr/bin/sudo: cannot execute binary file: Exec format error

If I start exagear from a root shell, and try to add a teamspeak user I get:

Code: Select all
root@raspberrypi:~# adduser teamspeak
Adding user `teamspeak' ...
Adding new group `teamspeak' (1001) ...
Adding new user `teamspeak' (1001) with group `teamspeak' ...
The home directory `/home/teamspeak' already exists.  Not copying from `/etc/skel'.
/usr/bin/passwd: 1: /usr/bin/passwd: Syntax error: word unexpected (expecting ")")
invalid combination of options
Try again? [y/N]

What am I doing wrong?

EDIT: a bit more info:

I followed the instructions from this thread (to re-install binfmt-support) but I still get the same error. Although, when re-installing binfmt-support, I did notice this warning:

Code: Select all
Setting up binfmt-support (2.1.5-1) ...
update-binfmts: warning: Couldn't load the binfmt_misc module.
update-binfmts: warning: Couldn't load the binfmt_misc module.
Processing triggers for systemd (215-17+deb8u5) ...

I don't know if that's a problem or not.

My system:

Code: Select all
pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.4.26-v7+ #915 SMP Thu Oct 20 17:08:44 BST 2016 armv7l GNU/Linux
pi@raspberrypi:~ $ cat /etc/issue
Raspbian GNU/Linux 8 \n \l
davedontmind
 
Posts: 3
Joined: Tue Jan 03, 2017 1:39 pm

Re: Exec format error

Postby davedontmind » Tue Jan 10, 2017 7:45 am

Hello? Is there anyone out there who can help me?
davedontmind
 
Posts: 3
Joined: Tue Jan 03, 2017 1:39 pm

Re: Exec format error

Postby seccipon » Thu Jan 12, 2017 9:36 am

It looks like you have a custom kernel without support of binfmt_misc module. If you don't understand why it happened you should just reinstall vanilla raspbian image.
seccipon
 
Posts: 6
Joined: Fri Nov 06, 2015 11:50 am

Re: Exec format error

Postby davedontmind » Tue Jan 17, 2017 1:55 pm

No, it's a standard install of Raspbian.

However, with some superb email support from Vadim, we came to the conclusion that something was corrupted in my setup.

Having re-installed Raspbian again from scratch on a re-formatted SD card, then installed exagear, everything now works as expected.
davedontmind
 
Posts: 3
Joined: Tue Jan 03, 2017 1:39 pm

Re: Exec format error

Postby lomew23 » Thu Dec 14, 2017 11:48 pm

Just verifying your password and also click on the sumdoglogin I'm thrilled that the Sumdog powerful discovering.
lomew23
 
Posts: 1
Joined: Thu Dec 14, 2017 11:46 pm

Re: Exec format error

Postby ShelleySmith » Sun Jan 14, 2018 9:17 am

Well your issue is a bit hectic according to rushmyessay legit suggestions but reinstalling the Raspbian would give good results as you have expected. As you have said your system was corrupted, first need to look into that criteria. I really hope it can be done through consulting experts.
ShelleySmith
 
Posts: 1
Joined: Sun Jan 14, 2018 9:16 am


Return to ExaGear Desktop

Who is online

Users browsing this forum: Google [Bot] and 2 guests