reinstall exagear desktop on the same Pi-different microSD?

reinstall exagear desktop on the same Pi-different microSD?

Postby DJChuck » Tue Feb 12, 2019 3:09 pm

Hi all,
I had Exagear and thereby Dropbox running on my Pi 3b+ (after no little doing, but never mind).
I subsequently had sound problems (as in: no sound out of the AUX jack) that proved to be more than I could resolve.
I decided to check things by starting all over with a new Raspian installation on a different microSD card. The good news is that with the new installation on a different microSD, the sound works.
But attempting to reinstall Exagear desktop - even though I bought and successfully installed the lifetime license previously - has been a problem.
Attempting to install the trial version doesn't work. After running
sudo apt-get update
running
sudo apt-get install exagear-desktop
results in "no file found" (approximately - going on memory here).

I don't want to pay for another license in hopes of downloading afresh -
suggestions?
Many thanks in advance.
- c.
DJChuck
 
Posts: 8
Joined: Tue Jan 22, 2019 4:19 am

Re: reinstall exagear desktop on the same Pi-different micro

Postby gramps98 » Tue Feb 12, 2019 3:24 pm

Hope someone can answer this. I have a similar problem. I have had to start over a number of times with my Raspberry Pi 3b + and its no easy task to get Exagear Desktop installed again.
gramps98
 
Posts: 4
Joined: Tue Feb 12, 2019 3:21 pm

Re: reinstall exagear desktop on the same Pi-different micro

Postby gramps98 » Wed Feb 13, 2019 9:26 am

I have had to start over on my Raspberry Pi 3 about a half dozen times and it's been quite painful. Support is very slow and I've usually figured out the problem before they respond.

Anyway, here's something that I hope will help. It's a link to the process by which I was able to get ExaGear-Desktop installed again. Once downloaded you might want to save the file in case you need it again.

https://thepi.io/how-to-run-x86-program ... pberry-pi/

Kudos to whomever it was that posted the information.
gramps98
 
Posts: 4
Joined: Tue Feb 12, 2019 3:21 pm

Re: reinstall exagear desktop on the same Pi-different micro

Postby DJChuck » Wed Feb 13, 2019 9:36 am

thanks very much for this!
one quick question: the download for exagear is for an earlier version - were you able to modify the command to download the latest version?
In any events, many thanks and I'll report on any successes / failures I may also enjoy ... (yes, support is slow ...)
best - c.
DJChuck
 
Posts: 8
Joined: Tue Jan 22, 2019 4:19 am

Re: reinstall exagear desktop on the same Pi-different micro

Postby gramps98 » Thu Feb 14, 2019 8:58 am

This has become quite interesting. I received an e-mail today stating that ExaGear has made the business decision to go out of business. They gave me a link to the latest version of their software and a PDF with instructions on how to upgrade to the latest version.

I haven't upgraded yet but I did download the latest file and the instructions. If you didn't receive a letter, here are the links that I received. Hope they work for you. If not we can figure out another way to get the files to you:

http://emails.eltechs.com/click/5acc7bf ... 25f7/event

http://emails.eltechs.com/click/5acc7bf ... fd36/event

http://emails.eltechs.com/click/5acc7bf ... 8e65/event

The links are for Pi 3, Pi2, and Instructions respectively. I'll check back to see if this worked for you. We can figure out another means of getting the files to you if not.
gramps98
 
Posts: 4
Joined: Tue Feb 12, 2019 3:21 pm

Re: reinstall exagear desktop on the same Pi-different micro

Postby DJChuck » Thu Feb 14, 2019 9:08 am

Hi - and thanks for this, much appreciated.
Happily, I got the same letter and set of links - this will keep me busy for a while ...
Such a pity - but I'm also hoping they'll keep the forum alive for awhile, so that these sorts of exchanges can continue as needed.

In fact, i did manage - on the second try - to install the version of Exagear included in the recommendations you provided: again, many thanks. The current difficulty is getting Dropbox to play nicely with it as well. There are some particular error messages that I've sent to Dropbox support: hope they can help sort it out.

Will post when more success (or failure) comes along ...

Again, many thanks on all fronts -
- c.
DJChuck
 
Posts: 8
Joined: Tue Jan 22, 2019 4:19 am

Re: reinstall exagear desktop on the same Pi-different micro

Postby gramps98 » Thu Feb 14, 2019 9:31 am

No problem. Dropbox works okay for me but it's not starting up when I fire up my Pi 3. I've had it working before, so I know I just have to find the right instructions on the right forum to fix it.

When I manually crank up Dropbox on the Pi I get the error about python-gpg for Ubuntu 16.10 and lower is not installed, and binary signatures can't be verified. However, the DB icon appears and it works as it should.

I'll post back my findings as well. We'll get it 'fingered' out. LOL
gramps98
 
Posts: 4
Joined: Tue Feb 12, 2019 3:21 pm

Re: reinstall exagear desktop on the same Pi-different micro

Postby DJChuck » Fri Feb 15, 2019 9:24 am

Hi again,
thanks for the encouragement!
I ran into similar errors the first time around of trying to resolve the issue.
What seems to have made the difference - i.e., after removing and then reinstalling Exagear - was following this set of directions for getting ready to install DP:

$ exagear
$ sudo apt-get update
$ sudo apt-get install libglapi-mesa libxcb-glx0 libxcb-dri2-0 libxcb-dri3-0 libxcb-present0 libxcb-sync1 libxshmfence1

This adds some additional packages as compared with a different instruction page from Exagear:
sudo apt-get install wget libxslt-dev libxxf86vm-dev xcb
I also used an earlier version of the Dropbox client:
sudo dpkg -i dropbox_2015.10.28_i386.deb; sudo apt-get install -f

Once this was installed, it started up a GUI that guided the downloading and unpacking of the python-GPG that you mention (I think).
This worked (as it did not in a previous effort using later instructions) - and the client promptly called up a browser for logging into my DB account. This led to another dialogue box that allow me to link the account to a given folder on the PI (actually, on an SSD mounted to it in an Element14 desktop enclosure) - and everything has been working perfectly since.

I don't know what disadvantages may accrue from using the older version - but there is a thread that addresses at least some of them.

You've probably already seen it and tried it - but if not, here's what I have on autostarting DB (again, from the older instructions from Exagear):

If you want Dropbox to autostart after system reboot execute following commands in the host ARM terminal:
$ arch
armv7
$ sudo su
$ printf '#!/bin/bash\nexec exagear -- $0 $@\n' > /usr/bin/dropbox
$ chmod +x /usr/bin/dropbox
$ exit

Let me know if that helps? I haven't tried it yet myself ...

Finally, my effort to ask for help with the Dropbox support team, complete with a log text that the client instructed me to send along to them, was met with a cheery but generic reply telling me that the Pi can't run Dropbox.
I've gently informed the support fellow that, oh yes, yes it can.

on we go - good luck!
DJChuck
 
Posts: 8
Joined: Tue Jan 22, 2019 4:19 am


Return to ExaGear Desktop

Who is online

Users browsing this forum: Bing [Bot] and 2 guests