Page 1 of 1

Exagear and Infinity Engine games - Planescape: Torment

PostPosted: Tue Mar 07, 2017 2:16 am
by fkirenicus
Some time ago I got MM6 and MM7 working on Exagear after some hassle, but now I wanted to try an old favorite, Planescape: Torment after having stumbled across this:

I use the latest version of Exagear on my trusted Nexus 9 tablet, now on Android 7.
I have the GOG DRM-free version of Planescape: Torment installed. In C:\Games\GOG\PST.
I have made a fresh reinstall since I wrote this post earlier today, and there are NO mods installed - except for the one that comes with the GOG version of the game; that mod that does something about DirectDraw.

The video above states
"3) Change the paths in the [alias] section of the Torment.ini file to
E:\Planescape Torment
E:\Planescape Torment\data

so I did that. Or, rather, I altered it to "E:\PST\" and "E:\PST\data" (see above).

When I start Exagear, the application finds the correct .exe file and and I can start the game, but when I do...

nothing happens.
Exagear's "please wait" screen appears for a couple of seconds, and then... it dies. The game doesn't start, and Exagear doesn't seem to respond much either.

The x86-stderr.txt file says thus:
argv = ['libubt'; '--vfs-kind'; 'guest-first'; '--path-prefix'; '/storage/emulated/0/Android/data/com.eltechs.erpg/files/image'; '--vpaths-list'; '/storage/emulated/0/Android/data/com.eltechs.erpg/files/image/.exagear/vpaths-list'; '-f'; '/usr/bin/wine'; '--fork-controller'; 'ua:.exagear-tracker-app10'; '--ipc-emul-server'; 'ua:com.eltechs.erpg'; '--tmp-dir'; '/storage/emulated/0/Android/data/com.eltechs.erpg/files/image/.exagear/tmp'; '--vfs-hacks=pels,ansep,tlsasws,'; '--file-name-replacements=/home/xdroid/.wine/dosdevices/c_,/home/xdroid/.wine/drive_c,/home/xdroid/.wine/dosdevices/d_,/storage/emulated/0/ExaGear,/home/xdroid/.wine/dosdevices/e_,/storage/emulated/0/ExaGear,'; '--socket-path-suffix'; 'erpg'; '--ubt-executable'; '/data/app/com.eltechs.erpg-1/lib/arm/'; '--ubt-loader'; '/data/app/com.eltechs.erpg-1/lib/arm/'; '--'; 'wine'; '/home/xdroid/.wine/dosdevices/d_/PST/Torment.exe'; ]
envp = ['HOME=/home/xdroid/'; 'LC_ALL=C'; 'DISPLAY=:10'; 'AXS_SOUND_SERVER_PORT=/tmp/.sound/AS10'; 'AXS_DSOUND_SERVER_PORT=/tmp/.sound/DS10'; 'EXADROID_DISABLE_SHORT_NAMES=y'; ]
Warning: could not find DOS drive for current working directory '/storage/emulated/0/ExaGear/PST', starting in the Windows directory.
wine: cannot find '/home/xdroid/.wine/dosdevices/d_/PST/Torment.exe'

I guess therefore that there's something wrong in the torment.ini path, but I can't get it to work... Have tried C:\PST, D:\PST and E:\PST, and even just \PST, but the game refuses to start.
I hope someone understands the error message better than I do... :-)

Re: Exagear and Infinity Engine games - Planescape: Torment

PostPosted: Thu Mar 16, 2017 12:18 pm
by fkirenicus
This was clearly an Android 7 issue - works now after latest update. :)
For the record: the guy in the video I referred to states that he had to set E:\ as the drive. I guess he has an SD card, since on my Nexus 9 I have to set D:\ as the drive (no SD card on that device).