Pi3 and diablo 2 LOD

Pi3 and diablo 2 LOD

Postby Glyph28 » Tue Aug 29, 2017 4:52 pm

Hello I'm posting to ask for help with the installation of diablo 2 lord of destruction on the raspberry pi 3 model b. I have had no issues installing the non expansion diablo 2, but I would like to play the expansion. After the installer hits 95% wine closes out and the terminal window stays up.. The last message in terminal is Killed.

I managed to get d2 running at 7-25fps which is acceptable for now but I need to be sure I can play the expansion before buying exagear desktop. (Currently on the trial version)


Anyways, thanks for help and time!

D2 lod diablo ii lord of destruction blizzard nox raspbian patch 1.14 d bnet pixel

Here is a video I made to help with framerate issues: https://youtu.be/XqEzP5sL8-w

If we can figure this out ide like to make a video for other people so they don't have as much trouble with this as I do.


fixed. apparently was a voltage issue.
Glyph28
 
Posts: 1
Joined: Tue Aug 29, 2017 4:46 pm

Re: Pi3 and diablo 2 LOD

Postby swagger » Mon Jul 23, 2018 7:45 pm

Thanks for mention of glide.
In exagear I can launch Diablo 2 like so

psuedo:
wine ~/.wine/drive_c/Program Files/Diablo II/Diablo II.exe -3dfx

All works great. Very important to setup GL properly.
https://docs.eltechs.com/install-and-co ... ion-on-rpi
And .NET https://eltechs.com/dotnet-raspberry-pi/

Problem:

Battle.net fails with

Error: instr on vaddr 0x5a84c45(invlpg_M) is unimplemented in ufx86. Exiting

Edit:

Exagear is running wine 2.02, but still I see on Wine 3: https://appdb.winehq.org/objectManager. ... &iId=25602 battle.net issues. From what I see in their logs, not the same error, but strangly, if you google 'ufx86 diablo' you will be taken to the winehq bug page.

If anyone figuring something out, I'd love to hear back!
swagger
 
Posts: 1
Joined: Mon Jul 23, 2018 1:57 pm


Return to ExaGear Desktop

Who is online

Users browsing this forum: No registered users and 7 guests