Dropbox [FIXED & WORKING]

Dropbox [FIXED & WORKING]

Postby JustinSB » Sun Apr 19, 2015 6:20 am

Hi,

I am trying to install & run Dropbox...

Following the notes provided by Dropbox themselves at https://www.dropbox.com/install I followed the info for the Dropbox Headless Install via command line & downloaded the 32bit version.

I extracted it using their instructions in a "Host System" shell, then launched an Exagear shell & issued the ~/.dropbox-dist/dropboxd command.

That's where everything stops! It just hangs with no response. It doesn't matter if I do this all in a root shell, or a normal user shell - absolutely nothing happens. It is supposed to output a link, on the command line, to get the token that I need to hook it all into my account. What am I doing wrong?

Is it possible to get Exagear to write log files, so I can find out what is wrong?

Thanks, J :-)
Last edited by JustinSB on Wed Apr 29, 2015 12:12 pm, edited 1 time in total.
JustinSB
 
Posts: 22
Joined: Sun Mar 29, 2015 2:36 am

Re: Dropbox

Postby pUnK » Sun Apr 19, 2015 7:38 am

Raspberry?
pUnK
 
Posts: 63
Joined: Thu Sep 18, 2014 11:03 am

Re: Dropbox

Postby JustinSB » Sun Apr 19, 2015 8:38 am

Hi, yes, sorry, I forgot to say.

Exagear is running on a Raspberry Pi 2, on stock Raspbian.
JustinSB
 
Posts: 22
Joined: Sun Mar 29, 2015 2:36 am

Re: Dropbox

Postby Eltechs » Tue Apr 21, 2015 10:14 am

Hi JustinSB!

We are going to release an update of ExaGear Desktop with better support for Raspbian very soon. Currently we are at the test phase. If you would like to become a beta-tester and check your case with Dropbox on this updated version of ExaGear Desktop, please, send e-mail on support[at]eltechs[dot]com.
Eltechs
 
Posts: 24
Joined: Fri Sep 19, 2014 8:43 am

Re: Dropbox

Postby JustinSB » Sat Apr 25, 2015 10:04 am

Hi Eltechs, thanks for the Beta-Tester info. I emailed support as soon as I read your message & am waiting for info on how to get on the Beta program. As soon as they get back to me I'll upgrade my systems & keep them posted on what I find.
JustinSB
 
Posts: 22
Joined: Sun Mar 29, 2015 2:36 am

Re: Dropbox

Postby hmsilva » Sat Apr 25, 2015 10:36 am

Hello,
Wen will be available?
I have buy today but did not know that still not 100% tested on RPI2.
Going to install raspbian today couse on arch linux cant make it work, dont know how to install binfmt-support, is the only pre missing now.
Is possible to have a beta to test?
Tanks
hmsilva
 
Posts: 4
Joined: Sat Apr 25, 2015 6:37 am

Re: Dropbox

Postby JustinSB » Sat Apr 25, 2015 3:34 pm

I just installed it on Raspbian as it came, & the only glitch that I had was having to create /etc/resolvconf before I could get the install to work. I use the mem-2g version, which they emailed me as soon as my payment had gone through. For the record though, I'm pretty sure that this is (currently) bleeding edge software & the Eltechs people are still beavering away to iron out the bugs. It's apparently lovely software, but I'm not sure that I would want to put it into a production type or mission critical environment just yet, for a few weeks at least. However, the things that I've got running seem to run normally, & stay normally stable too, so I may be being overly cautious, but as they say, YMMV...
J
JustinSB
 
Posts: 22
Joined: Sun Mar 29, 2015 2:36 am

Re: Dropbox on a Raspberry Pi [FIXED & WORKING]

Postby JustinSB » Wed Apr 29, 2015 1:33 pm

OK, I have tried this on exagear-guest-ubuntu-1204lts_7 & exagear-guest-ubuntu-1204lts_9 under exagear-mem2g_2227-1 running on installs of both Raspbian & Lubuntu, & it works, giving a normal Dropbox icon on the Task Bar & normal functionality.

The problem was that if you try to install & run Dropbox, it just hangs - with no error messages or intelligible logs. Thankfully, however, we are not the only people to have this problem...

If you read these 2 Dropbox forum posts (here & here) you will see that the problem is that Dropbox version 3 needs an upgraded version of glib, without which it just dies horribly. But version 2 doesn't have this problem...

Which leads us to this Dropbox forum post, which has a nice link to the version 2 file that we need.

Host shell commands are in blue, Exagear shell commands are in red.

Open a terminal session as your normal user account

user@RaspberryPi2:~$ sudo service exagear start
# you need the service running & if you start it now, you won't forget later

user@RaspberryPi2:~$ cd ~ && wget -O - "https://d1ilhw0800yew8.cloudfront.net/client/dropbox-lnx.x86-2.10.52.tar.gz" | tar xzf -
# this downloads & extracts the hidden directory '.dropbox-dist' to your home folder

user@RaspberryPi2:~$ sudo chattr +i -R .dropbox-dist
# this locks the files & stops Dropbox auto-upgrading to the version that doesn't work (can be undone with sudo chattr -i -R .dropbox-dist)

user@RaspberryPi2:~$ exagear
# launch an Exagear shell

user@RaspberryPi2:~$ sudo apt-get update
# if you don't run this first, it errors

user@RaspberryPi2:~$ sudo apt-get install libgtk2.0-0 libgdk-pixbuf2.0-0 libfontconfig1 libxrender1 libxrender-dev libx11-6 libglib2.0-0 libxft2 libfreetype6 libc6 zlib1g libpng12-0 libgcc1 libsm6 libjpeg62
# this is the list of all the extra libs that I have found that I need to get my things running.
# I know that they are not all needed for Dropbox, but each one has dug me out of a hole & as far as I'm concerned, they are really useful things to have installed on the guest system as a 'default'.

user@RaspberryPi2:~$ .dropbox-dist/dropboxd
# This runs the setup GUI. If it errors, you can see why & it will give you a nice path to a plain text log file. The last line in this log file will give you the lib that you are missing, & a quick Google search will tell you what package to install to get it. You should have all the libs that you need from the apt-get that you did earlier though, so you ought to be fine.
PLEASE NOTE: It takes just over 30 seconds to launch the setup, or once it is done, to launch Dropbox. I ended up timing it as I got so worried that nothing was happening, but now I have realized that it is normal. Also, don't unlock the .dropbox-dist folder & let it update, as it will stop working & silently hang next time you try to launch it!

If you read my other thread (here) & follow the instructions, the bug has been fixed in the latest version of Exagear & you can get the exagear service to autostart on boot. Once the service is running, you can create a desktop shortcut to run ~/.dropbox-dist/dropboxd so you don't need to launch it from a terminal any longer.

For the record, if you want to move your dropbox folder to a USB thumb drive or hard disk, there are a couple of gotchas...

presuming that you have /dev/sda1 mounted on /hdd in the host system via fstab, you need to recreate the mount points in the guest system & add them to the guest system vpaths-list

user@RaspberryPi2:~$ sudo mkdir /opt/exagear/images/ubuntu-1204lts/hdd
# using the host system, create the folders inside the guest folder structure

user@RaspberryPi2:~$ sudo chown user /opt/exagear/images/ubuntu-1204lts/hdd && sudo chgrp user /opt/exagear/images/ubuntu-1204lts/hdd
# change the user & group ownership to you (replace user with your username)

user@RaspberryPi2:~$ sudo nano /opt/exagear/images/ubuntu-1404lts/.exagear/vpaths-list
# add this line, save & close
/hdd/

# reboot to test that the service starts, & that your disk mounts, then launch an exagear shell & check that when you ls /hdd (in this example) that you can see your files. Then try launching your Dropbox shortcut, & after 30 seconds, if all is well, it should come up & start to sync.

Very little of this was my own work, I just pulled together info that was out there & found out what libs were missing for it all to work with Exagear & a Raspberry Pi 2, but hopefully this should help some people.

Justin :D
JustinSB
 
Posts: 22
Joined: Sun Mar 29, 2015 2:36 am

Re: Dropbox [FIXED & WORKING]

Postby JustinSB » Sun May 03, 2015 1:27 pm

I have also managed to get Dropbox running headless on a Raspberry Pi 2, with no need for the GUI. Following on from what I did above, all I did was to download the headless python script & run it. Because Dropbox takes 30 seconds to load on the Raspberry Pi 2, even without the GUI, it complains a little as it is starting, & then suddenly you are live. This would suit people who want to have their Dropbox folder shared out across their home network using Samba or NFS from a headless Raspberry Pi 2.
Code: Select all
cd ~ && wget https://www.dropbox.com/download?dl=packages/dropbox.py -O dropbox.py

try ./dropbox.py help to get the instructions
JustinSB
 
Posts: 22
Joined: Sun Mar 29, 2015 2:36 am


Return to ExaGear Desktop

Who is online

Users browsing this forum: Bing [Bot] and 6 guests

cron