SOLVED:Wine & DOS DRIVE ISSUE

SOLVED:Wine & DOS DRIVE ISSUE

Postby Canoa » Fri Aug 18, 2017 9:26 am

Hello,

on Cubietruck (ubuntu 16.04) I fresh installed exagear and later wine (without apt upgrade before) serveral times (before install all purged before).

On all tries to run winecfg I get the message "could not find DOD drives".

As I can see .wine ist set by default.

Any hint to solve this?

Best Regards,

Martin

UPDATE 2017-08-19
Connected with SSH x-forwarding I can run any x11-apps within guest. All seems to run fine. Using wine-1-8-1-eltechs.
Running winecfg within .wine/drive_c still have missing DOS drive

@ELTECHS
how and where to setup wine exactly to fix this issue?

UPDATE2
further installing of winetricks within guest-image shows following new issue: "Preparing to unpack .../systemd_229-4ubuntu4_i386.deb" creates a new error (already described in one of my older thread, still not answered by ELTECHS):

dpkg: warning: systemd: unable to stat config file '/etc/systemd/resolved.conf'
(= '/etc/systemd/resolved.conf'): Not a directory
dpkg: error processing archive /var/cache/apt/archives/systemd_229-4ubuntu4_i386.deb (--unpack):
unable to create '/etc/systemd/resolved.conf.dpkg-new' (while processing './etc/systemd/resolved.conf'): Not a directory
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
addgroup: The group `systemd-journal' already exists as a system group. Exiting.
chmod(/var/log) failed: Not a directory
Processing triggers for ureadahead (0.100.0-19) ...
Errors were encountered while processing:
/var/cache/apt/archives/systemd_229-4ubuntu4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
W: Operation was interrupted before it could finish


@ELTECHS:
Any hint to solve this?

SOLVED 2017-08-20
So I realized to have installed a quite old version of exagear that does not match my actual upgrade level of the host.
Previously installed V 1.5
Now installed: V 2.1 (wget http://eltechs.blob.core.windows.net/ex ... -cb.tar.gz)

Now:
    wine-1-6-2
    "apt update & apt upgrade" are running well
    winecfg is running through SSH x-forwarding!

For finalized upgrade I ran:

apt full-upgrade
after this:
    wine-2.0

To add other repositories:
apt install software-properties-common

Unfortunately the auto installed winetricks script in this package is outdated! ;)
When trying to install DLLs you get SHA1SUM Error.

My solution I found in web:
sudo apt remove winetricks

Then load the the actual one from original site:
    chmod +x winetricks

    sudo mv -v winetricks /usr/bin
Canoa
 
Posts: 3
Joined: Sat Oct 10, 2015 9:56 am

Return to ExaGear Desktop

Who is online

Users browsing this forum: No registered users and 5 guests

cron