Exec Format Error

Exec Format Error

Postby Dinofan137 » Thu Aug 17, 2017 6:56 am

Hi everyone,

I've been using Exagear on my RPI 3 for one year, and it worked very well so far. But I'm encountering a problem.

I'm trying to create dedicated servers for Trackmania games, by using x86 dedicated servers (servers that normally run on a x86 Ubuntu/Debian distribution).

I already achieved to create dedicated servers on my Raspberry Pi 3 for Trackmania Nations/United thanks to Exagear, and it works surprisingly well. Trackmania dedicated servers do not use a lot of processing power so things go pretty well even with several players and plugins.

Now, I'm trying to create a dedicated server for Trackmania², a program that use the same technology/engine than Trackmania United/Nations but with some major improvements.
This should be very simple, I just have to run one linux executable file in Exagear as I did before, but here's what happens when I did so :

Code: Select all
Starting /bin/bash  in the guest image /opt/exagear/images/debian-8
pi@raspberrypi:~ $ cd /home/pi/Maniaplanet/GameServer
pi@raspberrypi:~/Maniaplanet/GameServer $ ./ManiaPlanetServer
bash: ./ManiaPlanetServer: cannot execute binary file: Exec format error


And this make my dedicated server impossible to launch. From what I gathered on the Internet, Exec format error is shown when we try to launch an x86 software on an ARM device, or an ARM software on a x86 device. But this is what I get if I type arch :
Code: Select all
pi@raspberrypi:~/Maniaplanet/GameServer $ arch
i686


The program is run into Exagear's x86 mode, but I still can't launch it.
Do you have any ideas on how to solve this ?
Dinofan137
 
Posts: 1
Joined: Thu Aug 17, 2017 6:48 am

Return to ExaGear Desktop

Who is online

Users browsing this forum: Bing [Bot] and 3 guests

cron