Running wine through exagear on Rpi3

Running wine through exagear on Rpi3

Postby Zakattack » Sat May 20, 2017 9:04 am

So I've been trying to run wine in order to be able to run windows x86 programs(specifcially, mushclient494.exe) on my raspberry pi 3. These are the steps I've taken so far:

Installed Exagear: This is a 3rd party program that allows x86 applications to be run on RPi3 ARM. It cost me $25~ so i'm going to be quite frustrated if this ends up not working.

Got wine 1.8.1: Installing and running exagear allows you to sudo apt-get install wine, which I did. I then apt-get update'd and apt-get upgrade'd. 'wine --version' shows I'm running wine-1.8.1-eltechs. Various tutorials I've seen say that the next step in getting wine setup on a Rpi3 is running winecfg, but when that happens I get this:

Executing wine (wineserver32) 1.8.1 on Debian 8.8 (i386).
If something goes wrong, please rerun with "WINEDEBUG=err+all wine"
for more detailed debugging output.
Warning: could not find DOS drive for current working directory '/root', starting in the Windows directory.
Warning: could not find DOS drive for current working directory '/root', starting in the Windows directory.

I've tried running as root and as my normal user. I've tried just using wine filename.exe to no avail. I'm out of ideas. It seems that the graphical portion is what is failing, because 'wine cmd' works just fine. Any help is appreciated.

*Note* Please assume I'm an idiot and explain things in simple terms. I have no background with linux at all.
Zakattack
 
Posts: 2
Joined: Sat May 20, 2017 9:00 am

Re: Running wine through exagear on Rpi3

Postby Zakattack » Sat May 20, 2017 6:29 pm

I have removed and re-installed wine. Same issues. Won't let me use any wine commands, giving the above error command. Not sure what I'm doing wrong.
Zakattack
 
Posts: 2
Joined: Sat May 20, 2017 9:00 am

Re: Running wine through exagear on Rpi3

Postby Canoa » Sat Aug 19, 2017 8:40 am

Hello Zakattack,

I have the same issue with my installation on Cubietruck . Could You solve this meanwhile ? Did Eltechs gave you any hints?

Best Regards,

Canoa
Canoa
 
Posts: 3
Joined: Sat Oct 10, 2015 9:56 am


Return to ExaGear Desktop

Who is online

Users browsing this forum: Bing [Bot] and 2 guests