Issue with updates in guest

Issue with updates in guest

Postby bhlc » Wed Mar 22, 2017 5:01 pm

Hello,

I have an Odroid XU4 running Ubuntu 16.04.2 built on kernel 4.9.13. The kernel is compiled to include binfmt_misc as a module, and I've ensured binfmt_support is installed and up to date.

After freshly installing Exagear without error, I enter the guest:

Code: Select all
odroid@odroid:~$ exagear
Starting /bin/bash  in the guest image /opt/exagear/images/ubuntu-1604


...and updating package sources:

Code: Select all
odroid@odroid:~$ sudo apt-get update
sudo: unable to mkdir /var/run/sudo: Not a directory
[sudo] password for odroid:


I notice that there's some difficulty related to using sudo. It doesn't seem to prevent the apt-get command from continuing, though if I don't invoke sudo, apt-get will complain about permission. To circumvent this, I switch to root and then launch exagear.

My aim is to use Spotify, so I add the Spotify source, update package lists, and attempt to install Spotify:

Code: Select all
root@odroid:~# apt-get install spotify-client
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  acl adwaita-icon-theme aspell aspell-en at-spi2-core colord colord-data dbus
  dconf-gsettings-backend dconf-service dictionaries-common emacsen-common
  enchant fontconfig gconf-service gconf-service-backend gconf2-common
  glib-networking glib-networking-common glib-networking-services
  gsettings-desktop-schemas gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-x hicolor-icon-theme humanity-icon-theme hunspell-en-us
  iso-codes libaa1 libasn1-8-heimdal libasound2 libasound2-data libaspell15
  libatk-bridge2.0-0 libatk1.0-0 libatk1.0-data libatspi2.0-0 libavahi-client3
  libavahi-common-data libavahi-common3 libavc1394-0 libboost-filesystem1.58.0
  libboost-system1.58.0 libcaca0 libcairo-gobject2 libcairo2 libcap-ng0
  libcdparanoia0 libcolord2 libcolorhug2 libcroco3 libcups2 libcurl3 libdatrie1
  libdbus-1-3 libdbus-glib-1-2 libdconf1 libdrm-amdgpu1 libdrm-intel1
  libdrm-nouveau2 libdrm-radeon1 libdrm2 libdv4 libegl1-mesa libelf1
  libenchant1c2a libepoxy0 libexif12 libflac8 libfontconfig1 libfreetype6
  libgbm1 libgconf-2-4 libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libgeoclue0 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgphoto2-6
  libgphoto2-l10n libgphoto2-port12 libgpm2 libgraphite2-3 libgssapi3-heimdal
  libgstreamer-plugins-base1.0-0 libgstreamer-plugins-good1.0-0
  libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2.0-0
  libgtk2.0-bin libgtk2.0-common libgudev-1.0-0 libgusb2 libharfbuzz-icu0
  libharfbuzz0b libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal
  libhunspell-1.3-0 libhx509-5-heimdal libhyphen0 libiec61883-0 libieee1284-3
  libjack-jackd2-0 libjavascriptcoregtk-4.0-18 libjbig0 libjpeg-turbo8 libjpeg8
  libjson-glib-1.0-0 libjson-glib-1.0-common libkrb5-26-heimdal liblcms2-2
  libldap-2.4-2 libllvm3.8 libltdl7 libmirclient9 libmircommon5 libmirprotobuf3
  libnotify4 libnspr4 libnss3 libnss3-nssdb libogg0 libopus0 liborc-0.4-0
  libpam-systemd libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0
  libpciaccess0 libpixman-1-0 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libprotobuf-lite9v5 libproxy1v5 libraw1394-11
  librest-0.7-0 libroken18-heimdal librsvg2-2 librsvg2-common librtmp1
  libsamplerate0 libsane libsane-common libsasl2-2 libsasl2-modules
  libsasl2-modules-db libsecret-1-0 libsecret-common libshout3
  libsoup-gnome2.4-1 libsoup2.4-1 libspeex1 libsystemd0 libtag1v5
  libtag1v5-vanilla libthai-data libthai0 libtheora0 libtiff5 libtxc-dxtn-s2tc0
  libv4l-0 libv4lconvert0 libvisual-0.4-0 libvorbis0a libvorbisenc2 libvpx3
  libwavpack1 libwayland-client0 libwayland-cursor0 libwayland-egl1-mesa
  libwayland-server0 libwebkit2gtk-4.0-37 libwebkit2gtk-4.0-37-gtk2 libwebp5
  libwind0-heimdal libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0
  libxcb-render0 libxcb-shm0 libxcb-sync1 libxcb-xfixes0 libxcomposite1
  libxcursor1 libxdamage1 libxfixes3 libxi6 libxinerama1 libxkbcommon0 libxpm4
  libxrandr2 libxrender1 libxshmfence1 libxslt1.1 libxss1 libxtst6 libxv1
  notification-daemon policykit-1 systemd ubuntu-mono zenity zenity-common
Suggested packages:
  aspell-doc spellutils colord-sensor-argyll dbus-user-session | dbus-x11
  wordlist gvfs hunspell openoffice.org-hunspell | openoffice.org-core isoquery
  libasound2-plugins alsa-utils cups-common libdv-bin oss-compat
  libenchant-voikko libgd-tools geoclue gphoto2 gpm libvisual-0.4-plugins
  gstreamer1.0-tools jackd2 liblcms2-utils opus-tools pciutils libraw1394-doc
  librsvg2-bin avahi-daemon hplip libsane-extras sane-utils
  libsasl2-modules-otp libsasl2-modules-ldap libsasl2-modules-sql
  libsasl2-modules-gssapi-mit | libsasl2-modules-gssapi-heimdal speex
  systemd-ui systemd-container
Recommended packages:
  libavcodec54 | libavcodec-extra-54 libavformat54
The following NEW packages will be installed:
  acl adwaita-icon-theme aspell aspell-en at-spi2-core colord colord-data dbus
  dconf-gsettings-backend dconf-service dictionaries-common emacsen-common
  enchant fontconfig gconf-service gconf-service-backend gconf2-common
  glib-networking glib-networking-common glib-networking-services
  gsettings-desktop-schemas gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-x hicolor-icon-theme humanity-icon-theme hunspell-en-us
  iso-codes libaa1 libasn1-8-heimdal libasound2 libasound2-data libaspell15
  libatk-bridge2.0-0 libatk1.0-0 libatk1.0-data libatspi2.0-0 libavahi-client3
  libavahi-common-data libavahi-common3 libavc1394-0 libboost-filesystem1.58.0
  libboost-system1.58.0 libcaca0 libcairo-gobject2 libcairo2 libcap-ng0
  libcdparanoia0 libcolord2 libcolorhug2 libcroco3 libcups2 libcurl3 libdatrie1
  libdbus-1-3 libdbus-glib-1-2 libdconf1 libdrm-amdgpu1 libdrm-intel1
  libdrm-nouveau2 libdrm-radeon1 libdrm2 libdv4 libegl1-mesa libelf1
  libenchant1c2a libepoxy0 libexif12 libflac8 libfontconfig1 libfreetype6
  libgbm1 libgconf-2-4 libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libgeoclue0 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgphoto2-6
  libgphoto2-l10n libgphoto2-port12 libgpm2 libgraphite2-3 libgssapi3-heimdal
  libgstreamer-plugins-base1.0-0 libgstreamer-plugins-good1.0-0
  libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2.0-0
  libgtk2.0-bin libgtk2.0-common libgudev-1.0-0 libgusb2 libharfbuzz-icu0
  libharfbuzz0b libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal
  libhunspell-1.3-0 libhx509-5-heimdal libhyphen0 libiec61883-0 libieee1284-3
  libjack-jackd2-0 libjavascriptcoregtk-4.0-18 libjbig0 libjpeg-turbo8 libjpeg8
  libjson-glib-1.0-0 libjson-glib-1.0-common libkrb5-26-heimdal liblcms2-2
  libldap-2.4-2 libllvm3.8 libltdl7 libmirclient9 libmircommon5 libmirprotobuf3
  libnotify4 libnspr4 libnss3 libnss3-nssdb libogg0 libopus0 liborc-0.4-0
  libpam-systemd libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0
  libpciaccess0 libpixman-1-0 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libprotobuf-lite9v5 libproxy1v5 libraw1394-11
  librest-0.7-0 libroken18-heimdal librsvg2-2 librsvg2-common librtmp1
  libsamplerate0 libsane libsane-common libsasl2-2 libsasl2-modules
  libsasl2-modules-db libsecret-1-0 libsecret-common libshout3
  libsoup-gnome2.4-1 libsoup2.4-1 libspeex1 libtag1v5 libtag1v5-vanilla
  libthai-data libthai0 libtheora0 libtiff5 libtxc-dxtn-s2tc0 libv4l-0
  libv4lconvert0 libvisual-0.4-0 libvorbis0a libvorbisenc2 libvpx3 libwavpack1
  libwayland-client0 libwayland-cursor0 libwayland-egl1-mesa libwayland-server0
  libwebkit2gtk-4.0-37 libwebkit2gtk-4.0-37-gtk2 libwebp5 libwind0-heimdal
  libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-render0
  libxcb-shm0 libxcb-sync1 libxcb-xfixes0 libxcomposite1 libxcursor1
  libxdamage1 libxfixes3 libxi6 libxinerama1 libxkbcommon0 libxpm4 libxrandr2
  libxrender1 libxshmfence1 libxslt1.1 libxss1 libxtst6 libxv1
  notification-daemon policykit-1 spotify-client ubuntu-mono zenity
  zenity-common
The following packages will be upgraded:
  libsystemd0 systemd
2 upgraded, 209 newly installed, 0 to remove and 44 not upgraded.
Need to get 151 MB of archives.
After this operation, 579 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://repository.spotify.com stable/non-free i386 spotify-client i386 1:1.0.49.125.g72ee7853-22 [74.6 MB]
Get:2 http://archive.ubuntu.com/ubuntu xenial/main i386 libsystemd0 i386 229-4ubuntu4 [227 kB]


... a bunch of get rows...

Code: Select all
Get:211 http://archive.ubuntu.com/ubuntu xenial/main i386 zenity i386 3.18.1.1-1ubuntu2 [64.3 kB]
Fetched 151 MB in 37s (4029 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 13079 files and directories currently installed.)
Preparing to unpack .../libsystemd0_229-4ubuntu4_i386.deb ...
Unpacking libsystemd0:i386 (229-4ubuntu4) over (229-3ubuntu2) ...
Processing triggers for libc-bin (2.23-0ubuntu2) ...
Setting up libsystemd0:i386 (229-4ubuntu4) ...
Processing triggers for libc-bin (2.23-0ubuntu2) ...
(Reading database ... 13079 files and directories currently installed.)
Preparing to unpack .../systemd_229-4ubuntu4_i386.deb ...
Unpacking systemd (229-4ubuntu4) over (229-3ubuntu2) ...
dpkg: warning: systemd: unable to stat config file '/etc/systemd/resolved.conf'
 (= '/etc/systemd/resolved.conf'): Not a directory
dpkg: error processing archive /var/cache/apt/archives/systemd_229-4ubuntu4_i386.deb (--unpack):
 unable to create '/etc/systemd/resolved.conf.dpkg-new' (while processing './etc/systemd/resolved.conf'): Not a directory
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
addgroup: The group `systemd-journal' already exists as a system group. Exiting.
chmod(/var/log) failed: Not a directory
Processing triggers for ureadahead (0.100.0-19) ...
Errors were encountered while processing:
 /var/cache/apt/archives/systemd_229-4ubuntu4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Any idea what's going on?

Thanks!
bhlc
 
Posts: 1
Joined: Wed Mar 22, 2017 4:13 pm

Return to ExaGear Desktop

Who is online

Users browsing this forum: No registered users and 1 guest

cron