Problems installing Gecko for Eltechs Winebuild 1.8.1.

Problems installing Gecko for Eltechs Winebuild 1.8.1.

Postby koala_berry » Fri Feb 03, 2017 12:04 pm

I followed the instructions on https://eltechs.com/run-wine-on-raspberry-pi/, until the installation of Wine everything is fine. But I have big issues with installing Gecko.

If you download Wine normally it is supposed to install Mono and Gecko automatically (it asks you if you want to install Mono and Gecko when you start it), but Eltech´s 1.8.1. Wine build does not do that. So I assume it has to be installed manually. For Mono there is a good guide available and that works perfectly fine (https://eltechs.com/mono-raspberry-pi/). Thank you for that guide!

But when I try to install Gecko the same way that does not work. I looked on the Wine headquarters for the right Gecko version (https://wiki.winehq.org/Gecko) and the table tells me to use Gecko 2.40 for wine version-1.7.50 - wine version-1.9.2. So I did the following steps:

1.) Install exagear with install script (debian 8 guest image)
2.) $ exagear
3.) $ winecfg (and set emulated windows to windows 7)
4.) $ wget http://dl.winehq.org/wine/wine-gecko/2. ... 40-x86.msi
5.) $ cd ~/Downloads
6.) $ wine start wine_gecko-2.40-x86.msi

... And nothing happens. Wine tries to start and the Window is frozen. This is the debugging output I get:

Executing wine (wineserver32) 1.8.1 on Debian 8.2 (i386).
If something goes wrong, please rerun with "WINEDEBUG=err+all wine"
for more detailed debugging output.
fixme:exec:SHELL_execute flags ignored: 0x00000100
pi@raspberrypi:~/Downloads $ fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
wine: Assertion failed at address 0x5c8c0ddc (thread 000d), starting debugger...
*** stack smashing detected ***: C:\windows\system32\winemenubuilder.exe terminated
err:seh:start_debugger Couldn't start debugger ("") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
wine: Assertion failed at address 0x5c8c0ddc (thread 000d), starting debugger...
wine: Unhandled page fault on execute access to 0x5cce0e54 at address 0x5cce0e54 (thread 000d), starting debugger...
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x42e0df65
wine client error:d: read: Bad address
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot


... I am asking myself which Gecko version is needed by the eltechs wine 1.8.1. build?
... Does anybody else have this issues and knows how to fix them?
... Is there a possibility to write a guide that explains, how to install Wine Gecko with eltechs wine build (like the install guide for mono)? Maybe there is another way to install it?

Any help or support would be very much appreciated!!!!
koala_berry
 
Posts: 11
Joined: Wed Jan 25, 2017 1:47 pm

Re: Problems installing Gecko for Eltechs Winebuild 1.8.1.

Postby rickyshamilton » Tue Feb 07, 2017 8:13 am

Hi koala_berry!

I posted this same problem a few days ago, along with no LAN access for applications within Wine. I was unable to resolve it on the Raspberry, so I set up a Debian Jessie on an intel box to experiment with and had the same result. I ended up with circular dependencies blocking further progress.

I upgraded the distribution to Debian Stretch, and last night, after manually installing several supporting libraries, running the wine-gecko windows installer, and adding the path to wine-gecko manually to the registry (after referring to some registry docs on WineHQ) I managed to resolve the problem. I am going to go through the command line history later today, and will post a summary of the steps I took.

However, I think the current Exagear Wine package is going to face the same circular dependency issues I found when trying to fix in Jessie. The next step for me would be to try the steps I took on Stretch again on Jessie.

My conclusion so far is that Exagear Desktop is not a factor in this problem. I think if we can resolve this on Jessie, we can sort out the problem on the Raspberry.

More later....

Richard
rickyshamilton
 
Posts: 3
Joined: Thu Feb 02, 2017 12:40 pm

Re: Problems installing Gecko for Eltechs Winebuild 1.8.1.

Postby koala_berry » Tue Feb 07, 2017 1:09 pm

Hi Richard,

I am also still trying to figure out this problem. I upgraded the Debian 8 guest image with "apt-get update" and "apt-get upgrade", but this did not resolve the problem. I also played around with some registry keys, but nothing got it really working so far.

I would really appreciate, if you could share your findings, in case you make some progress on Jessie. Thank you for your reply!
koala_berry
 
Posts: 11
Joined: Wed Jan 25, 2017 1:47 pm

Re: Problems installing Gecko for Eltechs Winebuild 1.8.1.

Postby koala_berry » Fri Oct 06, 2017 3:17 pm

I just installed version 2.2 of Exagear and both Mono and Gecko install without problems. I just have to confirm it in an install dialog!!! Really great!
koala_berry
 
Posts: 11
Joined: Wed Jan 25, 2017 1:47 pm

Re: Problems installing Gecko for Eltechs Winebuild 1.8.1.

Postby linming0303 » Fri Nov 10, 2017 12:00 am

online shopping ged, rejected on the left side and threw to the r online shopping,ight, where he came to a stop on the hard shoulder. The damage to property is around 10.

000 euro Jeans,, the driver was not injured.

Our news now also once a day via
(Icon) (EUobserver) Could retroa women down jackets,ctively considered

55
n the police, the fire brigade and the DLRG one search usage on Saturday, Blouses,the 16.04.

2016 in niederstetten, Germany as an exercise in very real conditions document. Against 10.

48 h had a caller informed that she have found a bicycle and an IPhone near the Celtic square Hill in wild animal Bach.

The items would be in addition to a small pond.

After the first radio patrol car of police station arrived Bad Mergentheim in the locality could, on the basis of the overall circumstances, cannot be ruled out.

tha
linming0303
 
Posts: 21
Joined: Thu Nov 09, 2017 6:17 am

Re: Problems installing Gecko for Eltechs Winebuild 1.8.1.

Postby hellenjos » Mon Nov 20, 2017 4:23 am

I don’t know the problems arising with the installation of this device. Is there any solution for this. Help me to do the installation procedure. It is showing some error and I don’t know how to solve this error. So help me to correct the errors. Arcade and Party Rentals by Gems
hellenjos
 
Posts: 10
Joined: Mon Oct 09, 2017 9:26 pm


Return to ExaGear Desktop

Who is online

Users browsing this forum: Glassjaw0, Google [Bot] and 2 guests