Page 1 of 1

[Fixed] installation issue caused by missing dependencies

PostPosted: Sun Sep 04, 2016 12:45 am
by weatherwood
I'm trying to install Exagear on my Raspberry 2 running Raspbian GNU/Linux 8 (jessie). Since my main goal is to install Spotify, I used this installation command:

Code: Select all
sudo ./install-exagear.sh ubuntu-1404


The installation process gives the following error:

Code: Select all
Package realpath is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  coreutils

E: Package 'realpath' has no installation candidate


... and then it stops. Package realpath seems to be required, but it is replaced by coreutils.

Output of apt-cache search realpath:
Code: Select all
coreutils - GNU core utilities


Any clues on how to solve this?

Re: installation issue caused by missing dependencies

PostPosted: Tue Sep 06, 2016 6:58 am
by weatherwood
Issue was caused by a config error in my /etc/apt/sources.list file. Solved now.

Re: [Fixed] installation issue caused by missing dependencie

PostPosted: Thu Dec 06, 2018 9:55 am
by artus
I am running into this problem on an Odroid C2 (arm64) Ubuntu 18.3 installation. Tried a couple of suggested fixes, but no luck. What was the source list error that was suggested as a fix or other suggestions?

Thanks,
Jack