[Solved] Teamviewer exec format error

[Solved] Teamviewer exec format error

Postby draufsicht » Wed Apr 27, 2016 1:34 am

Hello,

I have an Raspi3 with Ubuntu Mate 15.10 installed on it. After installing exagear and all dependencies I started exagear as root with:
Code: Select all
#exagear

check architecture
Code: Select all
#arch
i686

try to start teamviewer:
Code: Select all
#teamviewer

result:
Code: Select all
init...
Checking setup...
/opt/teamviewer/tv_bin/script/tvw_profile: line 149: /opt/teamviewer/tv_bin/wine/bin/wine: cannot execute binary file: Exec format error


I get the same result when i try to start teamviewer as normal user (in the root/exagear chroot).
I installed exagear with this howto: http://forum.eltechs.com/viewtopic.php?f=4&t=83&sid=74aadd2e83af9cf613fe65e9bad453f0

Does anybody know what i do wrong?

Thank you!
draufsicht
 
Posts: 2
Joined: Wed Apr 27, 2016 12:55 am

Re: Teamviewer exec format error

Postby goha » Wed Apr 27, 2016 3:16 pm

Hello!
could you please check the type of your host ARM system:
$ [ $((`cat /proc/self/maps | grep stack | awk -F'-' '{print "0x"$1}'`)) -gt $((0x80000000)) ] && echo 3g/1g || echo 2g/2g

If it is 2g/2g then you need to apply specific patch:
$ wget http://s3.amazonaws.com/wine1.6-2g-2g/w ... -2g.tar.gz
$ tar -xzvf wine1.6-2g-2g.tar.gz
$ sudo ./teamviewer-fix-2g.sh
$ teamviewer

Details about the patch here: https://eltechs.com/run-teamviewer-on-raspberry-pi/
goha
 
Posts: 149
Joined: Wed Oct 08, 2014 9:22 am

Re: Teamviewer exec format error

Postby draufsicht » Fri Apr 29, 2016 3:16 am

Hello,

sry for my late answer, but i was a little bit busy these days,...

@goha - Thank you, that did the trick!
Everthing is working now.

Thank you for the help
Draufsicht
draufsicht
 
Posts: 2
Joined: Wed Apr 27, 2016 12:55 am

How to install TeamViewer

Postby Aabhapure » Wed Oct 05, 2016 11:53 pm

you face error when intalling team viewer you can learn hereHow to install TeamViewer for your pc.
Aabhapure
 
Posts: 1
Joined: Wed Oct 05, 2016 11:32 pm
Location: gujrat


Return to ExaGear Desktop

Who is online

Users browsing this forum: No registered users and 2 guests