unable to install exagear on Netgear ReadyNAS 102

unable to install exagear on Netgear ReadyNAS 102

Postby rustysnail26 » Thu Dec 17, 2015 8:23 am

Error message:

Code: Select all
...
 exagear depends on findutils.
 exagear depends on cron.
 exagear depends on alsa-base.
...


- 'apt-get install' on those dependencies returns '... already newest'.
- 'uname -a' is 'Linux <server_name> 4.1.13.armada.1 #1 SMP Sat Nov 21 15:57:29 PST 2015 armv7l GNU/Linux'
- Full details: http://natisbad.org/NAS2/

anyone able to shed a light? :?
I can give more info if required.

The ultimate goal is to be able to host SteamCMD.
rustysnail26
 
Posts: 2
Joined: Thu Dec 17, 2015 8:15 am

Re: unable to install exagear on Netgear ReadyNAS 102

Postby Armmaster » Thu Dec 17, 2015 3:49 pm

Could you attach full log of Exagear installing?
Armmaster
 
Posts: 86
Joined: Thu Oct 02, 2014 11:27 am

Re: unable to install exagear on Netgear ReadyNAS 102

Postby rustysnail26 » Fri Dec 18, 2015 9:08 am

Hi, thanks for the response.

Installation log below:
Code: Select all
ARCH=armv7l
HOST OS: debian
HOST OS VERSION: 7
EXAGEAR package: exagear_*-1_armhf.deb
EXAGEAR guest image package: 'exagear-guest-debian-7_*_all.deb'
Installing prerequisites...
Hit http://security.debian.org wheezy/updates InRelease
Ign http://mirrors.kernel.org wheezy InRelease
Hit http://security.debian.org wheezy/updates/main armel Packages
Hit http://security.debian.org wheezy/updates/main armhf Packages
Hit http://mirrors.kernel.org wheezy Release.gpg
Ign http://apt.readynas.com 6.4.1 InRelease
Hit http://mirrors.kernel.org wheezy Release
Get:1 http://apt.readynas.com 6.4.1 Release.gpg [490 B]
Hit http://mirrors.kernel.org wheezy/main armel Packages
Hit http://mirrors.kernel.org wheezy/main armhf Packages
Get:2 http://apt.readynas.com 6.4.1 Release [22.2 kB]
Get:3 http://apt.readynas.com 6.4.1/updates armel Packages [546 B]
Get:4 http://apt.readynas.com 6.4.1/apps armel Packages [38.2 kB]
Hit http://apt.readynas.com 6.4.1/main armel Packages
Hit http://apt.readynas.com 6.4.1/updates armhf Packages
Hit http://apt.readynas.com 6.4.1/apps armhf Packages
Hit http://apt.readynas.com 6.4.1/main armhf Packages
Fetched 61.4 kB in 15s (3,881 B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
bash is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
coreutils is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
findutils is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  realpath
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 16.4 kB of archives.
After this operation, 114 kB of additional disk space will be used.
Get:1 http://mirrors.kernel.org/debian/ wheezy/main realpath armel 1.18 [16.4 kB                                                                                                                                                             ]
Fetched 16.4 kB in 0s (20.5 kB/s)
Selecting previously unselected package realpath.
(Reading database ... 26117 files and directories currently installed.)
Unpacking realpath (from .../realpath_1.18_armel.deb) ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
curl is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libpipeline1
The following NEW packages will be installed:
  binfmt-support libpipeline1
0 upgraded, 2 newly installed, 0 to remove and 1 not upgraded.
Need to get 113 kB of archives.
After this operation, 303 kB of additional disk space will be used.
Get:1 http://mirrors.kernel.org/debian/ wheezy/main libpipeline1 armel 1.2.1-1 [                                                                                                                                                             34.9 kB]
Get:2 http://mirrors.kernel.org/debian/ wheezy/main binfmt-support armel 2.0.12                                                                                                                                                              [78.6 kB]
Fetched 113 kB in 2s (50.8 kB/s)
Selecting previously unselected package libpipeline1:armel.
(Reading database ... 26128 files and directories currently installed.)
Unpacking libpipeline1:armel (from .../libpipeline1_1.2.1-1_armel.deb) ...
Selecting previously unselected package binfmt-support.
Unpacking binfmt-support (from .../binfmt-support_2.0.12_armel.deb) ...
Setting up libpipeline1:armel (1.2.1-1) ...
Setting up binfmt-support (2.0.12) ...
update-binfmts: warning: Couldn't load the binfmt_misc module.
insserv: warning: script 'leafp2p' missing LSB tags and overrides
insserv: warning: script 'tftpr6' missing LSB tags and overrides
[ ok ] Starting binfmt-support (via systemctl): binfmt-support.service.
Processing triggers for libc-bin ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
cron is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  alsa-oss oss-compat
Recommended packages:
  alsa-utils
The following NEW packages will be installed:
  alsa-base
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 61.1 kB of archives.
After this operation, 134 kB of additional disk space will be used.
Get:1 http://mirrors.kernel.org/debian/ wheezy/main alsa-base all 1.0.25+3~deb7u1 [61.1 kB]
Fetched 61.1 kB in 1s (47.1 kB/s)
Selecting previously unselected package alsa-base.
(Reading database ... 26146 files and directories currently installed.)
Unpacking alsa-base (from .../alsa-base_1.0.25+3~deb7u1_all.deb) ...
Setting up alsa-base (1.0.25+3~deb7u1) ...
Installing the binary translator...
Selecting previously unselected package exagear.
(Reading database ... 26161 files and directories currently installed.)
Unpacking exagear (from exagear_2367-1_armhf.deb) ...
dpkg: dependency problems prevent configuration of exagear:
 exagear depends on findutils.
 exagear depends on cron.
 exagear depends on alsa-base.

dpkg: error processing exagear (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 exagear


sources.list:
Code: Select all
deb http://apt.readynas.com/packages/readynasos 6.4.1 updates apps main

deb http://mirrors.kernel.org/debian wheezy main
deb http://security.debian.org/ wheezy/updates main


Second installation:
Code: Select all
System memory configuration is determined as 3g/1g
ARCH=armv7l
HOST OS: debian
HOST OS VERSION: 7
EXAGEAR package: exagear_*-1_armhf.deb
EXAGEAR guest image package: 'exagear-guest-debian-7_*_all.deb'
Installing prerequisites...
Hit http://security.debian.org wheezy/updates InRelease
Ign http://apt.readynas.com 6.4.1 InRelease
Ign http://mirrors.kernel.org wheezy InRelease
Hit http://security.debian.org wheezy/updates/main armel Packages
Hit http://security.debian.org wheezy/updates/main armhf Packages
Hit http://mirrors.kernel.org wheezy Release.gpg
Get:1 http://apt.readynas.com 6.4.1 Release.gpg [490 B]
Hit http://mirrors.kernel.org wheezy Release
Get:2 http://apt.readynas.com 6.4.1 Release [22.2 kB]
Hit http://mirrors.kernel.org wheezy/main armel Packages
Get:3 http://apt.readynas.com 6.4.1/updates armel Packages [546 B]
Hit http://mirrors.kernel.org wheezy/main armhf Packages
Get:4 http://apt.readynas.com 6.4.1/apps armel Packages [38.2 kB]
Hit http://apt.readynas.com 6.4.1/main armel Packages
Hit http://apt.readynas.com 6.4.1/updates armhf Packages
Hit http://apt.readynas.com 6.4.1/apps armhf Packages
Hit http://apt.readynas.com 6.4.1/main armhf Packages
Fetched 61.4 kB in 16s (3,611 B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
bash is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 exagear:armhf : Depends: findutils:armhf but it is not going to be installed
                 Depends: cron:armhf but it is not going to be installed
                 Depends: alsa-base:armhf but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


Appreciate the help.
rustysnail26
 
Posts: 2
Joined: Thu Dec 17, 2015 8:15 am

Re: unable to install exagear on Netgear ReadyNAS 102

Postby Armmaster » Fri Dec 18, 2015 3:10 pm

Did you try:
$ sudo apt-get -f install

?
Armmaster
 
Posts: 86
Joined: Thu Oct 02, 2014 11:27 am


Return to ExaGear Desktop

Who is online

Users browsing this forum: Bing [Bot] and 4 guests

cron