Problem with TCP port on Raspberry Pi 3b with HLDS

Problem with TCP port on Raspberry Pi 3b with HLDS

Postby Nicox » Sun Jan 28, 2018 2:49 pm

Hello! So i'm moving from big size server to Raspberry PI.
Before i was using Arch Linux, and on the raspberry i'm with Raspbian.
I heard for ExaGear and i bought it right away. Its working with my HLDS (Half-Life Dedicated Server) BUT...
There is one plugin called WebMod. Basically it open webpage on the same port like the game server i.e. 27015 and you can see there statistics for the game.
The problem is, that this port can't be open. When i'm trying to open the page, says: ERR_CONNECTION_REFUSED.
I was trying to allow the TCP port like this:
Code: Select all
sudo iptables -A INPUT -p tcp --dport 27015 -s 172.16.1.201/24 -j ACCEPT

or this:
Code: Select all
sudo iptables -A INPUT -p tcp -m tcp --sport 27000:27030 --dport 1025:65355 -j ACCEPT

(saw these commands with udp, and tried to open the tcp too) BUT...
Code: Select all
sudo: iptables: command not found

"sudo netstat -lptu" returns:
Code: Select all
udp        0      0 172.16.1.201:26900      0.0.0.0:*                           5097/ubt_x32a32_al 
udp        0      0 172.16.1.201:27015      0.0.0.0:*                           5097/ubt_x32a32_al

but no tcp :/ I'm not really sure is that the problem, but i don't have any ideas.
If someone could help me, i will be very thankful :)
Nicox
 
Posts: 2
Joined: Sun Jan 28, 2018 2:35 pm

Re: Problem with TCP port on Raspberry Pi 3b with HLDS

Postby Armmaster » Fri Feb 02, 2018 6:11 pm

Hello Nicox,

You are trying to use iptables inside x86-guest. First of all try to run this commands in host rpi machine.
Armmaster
 
Posts: 85
Joined: Thu Oct 02, 2014 11:27 am

Re: Problem with TCP port on Raspberry Pi 3b with HLDS

Postby Nicox » Sat Feb 10, 2018 11:36 am

Armmaster wrote:Hello Nicox,

You are trying to use iptables inside x86-guest. First of all try to run this commands in host rpi machine.


I tried everything... Nothing works i even uninstalled iptables, and still nothing.
Nicox
 
Posts: 2
Joined: Sun Jan 28, 2018 2:35 pm


Return to ExaGear Desktop

Who is online

Users browsing this forum: No registered users and 2 guests