Running x86 program that needs DirectX on Raspberry Pi 3B?

Running x86 program that needs DirectX on Raspberry Pi 3B?

Postby Arno » Sat Jan 13, 2018 4:32 am

Hi everyone,

I'm currently doing a project in which I'm trying to run the software used for the Samsung Gear 360 on the Raspberry Pi 3 Model B. The goal is to use that software to start a live stream with the Gear 360.
The software is called 'Gear 360 Action Director' and so it's a x86 based program.

I've done some research on running x86 programs on a Pi and found Exagear. So I installed this software and I also installed Wine.
After I had done this I was able to run exe files. So I tried to install the program. And it did open the installer and was actually installing the program but it ran into an error. Which said that Direct X 10 or above is needed to install the program.

After some more research, I installed Winetricks and installed the DLL file for Direct X 10.
But now I'm still getting that same error.
I don't know what I can do about this or if there is any way to get Direct X 10 or above installed.

Any thoughts?

Thank you in advance!
Posts: 1
Joined: Sat Jan 13, 2018 4:29 am

Re: Running x86 program that needs DirectX on Raspberry Pi 3

Postby Armmaster » Fri Feb 02, 2018 5:34 pm

Hi Arno,

Several days ago wine 3.0 was released and it claims support for DirectX. So, one possible way is to install new wine in x86-guest system and try to launch your app again.
But there are at least two possible problems:
1. wine 2.* has specific memory layout and cannot be directly run on rpi's linux kernel. That's why inside exagear patched wine is used.
2. DirectX 10 implementation in wine may demand higher versions of GL that are unsupported in RPI OpenGL drivers.

We are going to check wine 3.0 compatibility with rpi linux kernel and fix it if there are any issues. But cannot tell how much time does it take.
Posts: 86
Joined: Thu Oct 02, 2014 11:27 am

Return to ExaGear Desktop

Who is online

Users browsing this forum: Google [Bot] and 2 guests