Run-time error '7' Out of memory

Run-time error '7' Out of memory

Postby insanity213 » Wed Dec 27, 2017 11:17 am

I'm trying to use Exagear with Wine on an RPi3 to run one very small Win32 application. Installation of Exagear and Wine was successful. Installation of my app was also successful. Upon 1st attempt to run I was prompted to install some additional components (Mono and Some .net stuff iirc?) and they all installed fine. When I actually went to run the app itself I got "Run-time error '7' Out of memory". There was plenty of physical RAM available and the swap space was never touched. I'm sure there's plenty of memory available. Any idea what run-time error 7 really means? Googling didn't reveal much...

Edit:

Ran from the CLI:

fixme:olepicture:OleLoadPictureEx (0xac0384,1086,0,{7bf80980-bf32-101a-8bbb-00aa00300cab},x=0,y=0,f=0,0x32f984), partially implemented.
fixme:olepicture:OleLoadPictureEx (0xac0384,197,1,{7bf80980-bf32-101a-8bbb-00aa00300cab},x=0,y=0,f=0,0x32f954), partially implemented.
fixme:olepicture:OLEPictureImpl_SaveAsFile (0x131400)->(0x1afb88, 0, (nil)), hacked stub.
fixme:olepicture:OleLoadPictureEx (0xac6084,1086,0,{7bf80980-bf32-101a-8bbb-00aa00300cab},x=0,y=0,f=0,0x32f570), partially implemented.
err:heap:HEAP_CreateSystemHeap system heap base address 0x80000000 not available
fixme:olepicture:OLEPictureImpl_FindConnectionPoint no connection point for {33ad4f92-6699-11cf-b70c-00aa0060d393}

Everything I found related to that error was from 10 years ago or more so not much help there...
insanity213
 
Posts: 1
Joined: Wed Dec 27, 2017 11:14 am

Return to ExaGear Desktop

Who is online

Users browsing this forum: No registered users and 6 guests

cron