Wine on Odroid C1 problem.

Wine on Odroid C1 problem.

Postby pawels » Sun Oct 11, 2015 9:26 am

Hi,

I'm trying wine (various versions) with exagear 1.1 on Odroid C1 with Ubuntu 14.04 with almost no luck. I can install aplications but windows are black or almost black causing wine unusable. Winecfg is also unusable - completly black window and black/invisible mouse pointer. Can anybody help or suggest solution ?

Regards

Pawel
pawels
 
Posts: 5
Joined: Sun Oct 11, 2015 9:02 am

Re: Wine on Odroid C1 problem.

Postby Armmaster » Sun Oct 11, 2015 2:33 pm

Could you specify:

1. Host OS
2. Guest OS.
3. Put here the result of this command:
[ $((`cat /proc/self/maps | grep stack | awk -F'-' '{print "0x"$1}'`)) -gt $((0x80000000)) ] && echo "3g/1g" || echo "2g/2g"
4. What wine version do you use?
5. Some exact application example that did not work.
Armmaster
 
Posts: 86
Joined: Thu Oct 02, 2014 11:27 am

Re: Wine on Odroid C1 problem.

Postby pawels » Sun Oct 11, 2015 2:54 pm

1. Host OS : Ubuntu 14.04.
2. Guest OS: Ubuntu 14.04 ( from exagear).
3. 3g/1g .
4. wine-1.7.50 , but tried with earlier versions, teamviewer has own part of wine.
5. teamviewer , teraterm, winecfg.

There is another issue - I tried to use vnc as remote desktop and run teamviewer - both windows was ok, but it was impossible to make incoming connection and login to my teamviewer account also. Outgoing connections work well - I can control another computers without problems.
pawels
 
Posts: 5
Joined: Sun Oct 11, 2015 9:02 am

Re: Wine on Odroid C1 problem.

Postby Armmaster » Sun Oct 11, 2015 3:18 pm

I didn't catch - teamviewer is launching under Exagear but there are some problems with connection and etc, am I right?
Or it even didn't start?
Armmaster
 
Posts: 86
Joined: Thu Oct 02, 2014 11:27 am

Re: Wine on Odroid C1 problem.

Postby pawels » Mon Oct 12, 2015 2:27 am

Yes, teamviewer is launching under exagear but its window is black except some elements and has problem with incoming connections - doesn't detect them.
pawels
 
Posts: 5
Joined: Sun Oct 11, 2015 9:02 am

Re: Wine on Odroid C1 problem.

Postby pawels » Mon Oct 12, 2015 3:55 am

Here is photo of Teamviewer window ( screenshots are ok )
Image.
pawels
 
Posts: 5
Joined: Sun Oct 11, 2015 9:02 am

Re: Wine on Odroid C1 problem.

Postby Armmaster » Mon Oct 12, 2015 4:29 pm

Hm, it seems that an issue is connected with your X-server or video driver.
I've googled a little and found that Odroid C1 have some problems with that:

http://archlinuxarm.org/forum/viewtopic.php?f=60&t=8276
http://forum.odroid.com/viewtopic.php?f=117&t=7745

Could you attach a /var/log/Xorg.0.log file after launching Teamviewer under Exagear?
And could you try to launch smth like xcalc natively and under Exagear? Will it work correctly in both cases?
Armmaster
 
Posts: 86
Joined: Thu Oct 02, 2014 11:27 am

Re: Wine on Odroid C1 problem.

Postby pawels » Tue Oct 13, 2015 2:23 pm

I can confirm - both versions of xcalc (native and under exagear) work properly without any problems. File /var/log/Xorg.0.log is attached.
Attachments
Xorg.0.zip
(5.83 KiB) Downloaded 208 times
pawels
 
Posts: 5
Joined: Sun Oct 11, 2015 9:02 am

Re: Wine on Odroid C1 problem.

Postby Armmaster » Sat Oct 24, 2015 5:39 am

As I can see there are errors in your X-server log. So this means that on Odroid C1 there are some issues with video drivers.
Without having this device on hand I can only suggest to update OS/drivers, may be this helps.
Armmaster
 
Posts: 86
Joined: Thu Oct 02, 2014 11:27 am

Re: Wine on Odroid C1 problem.

Postby adan_skarzynski » Mon Mar 14, 2016 2:24 pm

Has anybody resolve this problem? I have the same problem with Odroid C1+ and teamviewer under ubuntu 14.04.
adan_skarzynski
 
Posts: 1
Joined: Mon Mar 14, 2016 2:21 pm

Next

Return to ExaGear Desktop

Who is online

Users browsing this forum: No registered users and 6 guests